Back to overview
Resolved

Downtime in Email Service in us-east-1

Sep 1, 2026 at 7:28pm UTC
Affected services
Application (app.devrev.ai)
Conversation and Ticket Management

Resolved
Sep 1, 2026 at 8:35pm UTC

We are pleased to inform you that the issue affecting our outbound email service has been resolved, and ticket replies, one-time passcodes (OTPs), and notifications are now being delivered normally. Thank you for your patience.

Created
Sep 1, 2026 at 7:28pm UTC

We are currently experiencing an issue with our outbound email service, which may cause delays or errors in delivering ticket replies, one-time passcodes (OTPs), and notifications. Our team is actively working to resolve this and restore normal service. We appreciate your patience and will provide updates as soon as possible.