Delayed search indexing for recently updated records
Resolved
Sep 10, 2026 at 11:14am UTC
We are pleased to inform you that the recent issue involving search indexing delays for newly created or updated records in the US region has been successfully resolved. The underlying cause was identified and addressed promptly, ensuring that search functionality is now operating normally and all recent records are appearing in search results as expected. We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our services are stable and operating normally. If you experience any further issues or have questions, please do not hesitate to contact us.
Affected services
Created
Sep 9, 2026 at 5:25pm UTC
We're currently investigating an issue where recently created or updated records may not appear in search results promptly. This affects search and retrieval of latest objects in our US region. Existing data and other functionality are unaffected. We sincerely apologize for the inconvenience this may be causing. Our team has identified the cause and is actively deploying a fix. We will keep this page updated as the backlog clears and normal indexing resumes.
Affected services