Back to overview
Resolved

Elevated API latency in the India region

Sep 11, 2026 at 12:10pm UTC
Affected services
Application (app.devrev.ai)
API (api.devrev.ai)
Computer

Resolved
Sep 11, 2026 at 12:40pm UTC

We have resolved the incident affecting API performance in the India (Mumbai) region. Our engineering team identified and mitigated the root cause, and all systems are now operating normally. We apologize for the disruption and appreciate your patience.

Created
Sep 11, 2026 at 12:10pm UTC

We're currently investigating elevated latency and intermittent timeouts affecting some API requests and in-app experiences for customers hosted in the India (Mumbai) region. You may notice slower page loads, delayed API responses, or occasional timeouts in chat and support workflows. Our engineering team has identified the likely cause and is actively working on mitigation. We apologize for the inconvenience and will post an update as soon as we have more information.