Back to overview
Resolved

Performance Degradation: Delayed Execution of Workflows (Timeline Comments & Events

Sep 20, 2026 at 11:30am UTC
Affected services
Application (app.devrev.ai)
Timeline
Conversation and Ticket Management
Workflows and Automations

Resolved
Sep 20, 2026 at 1:52pm UTC

The issue causing delays in processing timeline comments and event-based workflows has been fully resolved. All queued workflows have caught up, and execution times have returned to normal performance levels.

Our team will continue to monitor system performance to ensure stability. Thank you for your patience.

Created
Sep 20, 2026 at 11:30am UTC

We are currently investigating an issue causing delayed execution for timeline comment and event-based workflows. Impacted workflows may experience latency before triggering. Our engineering team is actively working to resolve the issue and restore normal performance. We sincerely apologize for any inconvenience or operational disruption this may cause, and we will post updates as new information becomes available.