Intermittent access issues
Resolved
Sep 22, 2026 at 4:20pm UTC
We are pleased to inform you that the recent database rate limit errors have been fully resolved. These issues were causing intermittent disruptions to your experience, but our team has taken the necessary steps to restore normal service. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our service is now stable and functioning as expected. If you continue to experience any issues or have concerns, please do not hesitate to contact us. Thank you for your continued trust.
Affected services
Created
Sep 22, 2026 at 1:20pm UTC
We’re investigating an issue that may prevent some users from accessing DevRev or completing sign-in-related actions. Our team is actively working to restore normal access and will provide updates as more information becomes available.
Affected services