Back to overview
Resolved

DevRev app down in the India region

Sep 26, 2026 at 6:10am UTC
Affected services
Application (app.devrev.ai)
API (api.devrev.ai)
Authentication (auth.devrev.ai)
Support Portal (support.devrev.ai)
Plug Platform
Issue Management
Marketplace
Search
Timeline
Vistas
Conversation and Ticket Management
Computer
Workflows and Automations
Analytics & Dashboards

Resolved
Sep 26, 2026 at 9:30am UTC

We are pleased to inform you that the recent outage affecting all organizations in the ap-south-1 region has been fully resolved. The issue was caused by a service disruption that has now been addressed. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our services are stable and functioning normally.

Updated
Sep 26, 2026 at 8:20am UTC

We're seeing some access return for customers in the India region, but DevRev remains slow and may still be unavailable at times. We've added capacity and are continuing to work on restoring reliable service. We're sorry for the disruption and will keep this page updated as we verify improvements.

Created
Sep 26, 2026 at 6:10am UTC

We’re investigating an issue that may prevent some customers in the India region from signing in to or using DevRev. Customers may see a “Something went wrong” message. Our team is working to restore access and will provide an update as we learn more.