Back to overview
Downtime
Data is not loading
Jul 10 at 10:00pm UTC
Affected services
Application (app.devrev.ai)
Resolved
Jul 10 at 11:53pm UTC
The application is now up and running normally. Engineering is continuing to monitor the situation for any degradation.
Affected services
Application (app.devrev.ai)
Updated
Jul 10 at 10:28pm UTC
Engineering has identified the issue and is actively working to resolve it.
Affected services
Application (app.devrev.ai)
Created
Jul 10 at 10:00pm UTC
app.devrev.ai is experiencing technical difficulties loading data on the UI. Engineering is actively working on resolving this issue.
Affected services
Application (app.devrev.ai)