Back to overview
Downtime
AWS outage impacting DevRev degraded experience
Oct 20 at 06:50am UTC
Affected services
Application (app.devrev.ai)
Resolved
Oct 20 at 09:46am UTC
The AWS outage in the us-east-1 region has been resolved. Access to DevRev has been restored, and all services are now operating normally.
Affected services
Created
Oct 20 at 06:50am UTC
AWS is currently experiencing an outage in the us-east-1 region, which is impacting access to DevRev for users in this region.
Affected services