Back to overview
Degraded

Delay in Workflow Trigger

Oct 21 at 01:36pm UTC
Affected services
Application (app.devrev.ai)

Resolved
Oct 21 at 02:47pm UTC

We are pleased to inform you that the recent delays and lag issues with the Workflow Trigger Node have been resolved. The underlying cause has been addressed, and our team has taken steps to ensure smoother performance moving forward. We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, the service is now stable and functioning as expected. If you experience any further issues or have questions, please don't hesitate to reach out to our support team.

Created
Oct 21 at 01:36pm UTC

We are currently experiencing delays with the workflow trigger system, which may cause some processes to start later than expected. Our team is actively working to resolve the issue and restore normal service. We appreciate your patience and will provide updates as soon as more information is available.