Service Disruption Affecting Customer Accounts
Resolved
Oct 28 at 12:46pm UTC
We are pleased to inform you that the recent service outage has been fully resolved. The issue, which temporarily affected some of our services, has been addressed through our standard procedures to restore normal operation. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our service is now stable and functioning as expected. If you experience any further issues or have questions, please do not hesitate to contact us. Thank you for your continued trust and support.
Affected services
Created
Oct 28 at 10:42am UTC
We are currently experiencing a service disruption that may impact your ability to access your account. Our team is actively working to resolve the issue and restore normal service as quickly as possible. We will provide updates as we have more information. This is an intermittent issue, you may or may not experience this.
Affected services