Back to overview
Degraded

Email Notification Delivery Disruption

Feb 02 at 10:00am UTC
Affected services
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)

Resolved
Feb 03 at 10:56am UTC

We are pleased to inform you that the recent email notification issues have been fully resolved. The incident was caused by a change email provider settings, which temporarily affected email delivery. Our team has taken the necessary steps to update and secure the system, restoring normal service. We apologize for any inconvenience this may have caused and appreciate your patience and understanding. Rest assured, our service is now stable and functioning as expected. If you experience any further issues or have questions, please don't hesitate to contact us.

Created
Feb 02 at 10:00am UTC

We experienced a temporary disruption in email notifications due to a recent update to our system. The issue has been identified and resolved, and email delivery has returned to normal. We apologize for any inconvenience this may have caused.