Back to overview
Degraded

Login Issues with DevRev Organization Services

Feb 22 at 05:37pm UTC
Affected services
Application (app.devrev.ai)

Resolved
Feb 22 at 07:09pm UTC

We are pleased to inform you that the recent login issues affecting login access for DevRev users have been fully resolved. The outage was caused by a temporary service disruption, which has now been addressed. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our services are now stable and functioning normally. If you experience any further issues or have questions, please do not hesitate to contact us. Thank you for your continued trust.

Updated
Feb 22 at 06:51pm UTC

The disruptions affecting login access for DevRev users have been mitigated, but we are still closely observing the system in case of further issues

Created
Feb 22 at 05:37pm UTC

We are currently experiencing a temporary disruption affecting login access for DevRev users. Our team is actively working to resolve the issue and restore normal service. We appreciate your patience and will provide updates as soon as possible.