Back to overview
Downtime

Computer Downtime

Mar 25, 2026 at 03:23pm UTC
Affected services
Computer
Computer
Computer
Computer
Computer

Resolved
Mar 25, 2026 at 04:33pm UTC

We are pleased to inform you that the recent unresponsiveness issue has been fully resolved. The underlying cause has been identified and addressed to restore normal service operation. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our team has taken steps to ensure the stability of the service moving forward. If you experience any further issues or have questions, please do not hesitate to contact us.\
\
The issue affected all of our agents and not only Computer.\
\
Time frame of the incident was from 2:26 PM UTC to 3:29 PM UTC.

Updated
Mar 25, 2026 at 04:33pm UTC

We are pleased to inform you that the recent unresponsiveness issue has been fully resolved. The underlying cause has been identified and addressed to restore normal service operation. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our team has taken steps to ensure the stability of the service moving forward. If you experience any further issues or have questions, please do not hesitate to contact us.\
\
Time frame of the incident was from 7:56PM IST to 8:59PM IST.

Updated
Mar 25, 2026 at 04:25pm UTC

We are currently experiencing a temporary issue affecting Computer, which may cause unresponsiveness. Our team is actively working to resolve the problem and restore normal service as quickly as possible. We appreciate your patience and will provide updates as soon as more information is available.

Created
Mar 25, 2026 at 03:23pm UTC

We are currently experiencing a temporary issue affecting Computer, which may cause unresposivnes. Our team is actively working to resolve the problem and restore normal service as quickly as possible. We appreciate your patience and will provide updates as soon as more information is available.