Service Access Issue Under Investigation
Resolved
Apr 6, 2026 at 6:57pm UTC
We are pleased to inform you that the reported issue has now been resolved. The concern you experienced has been thoroughly reviewed and addressed by our team. We apologize for any inconvenience this may have caused and appreciate your patience and understanding throughout the process. Rest assured, our service is now stable and functioning as expected. If you continue to experience any issues or have further questions, please don't hesitate to reach out to us. Thank you for being a valued customer.
Affected services
Created
Apr 6, 2026 at 2:40pm UTC
We are aware of a reported issue affecting some customers and are actively investigating the situation. Our team is working to resolve the problem as quickly as possible and will provide updates as they become available. We appreciate your patience and understanding.
Affected services