Back to overview
Degraded

Service Access Disruption for Some Users

Apr 14, 2026 at 12:12pm UTC
Affected services
Application (app.devrev.ai)

Resolved
Apr 14, 2026 at 2:27pm UTC

We are pleased to inform you that the recent outage affecting DevRev services has been fully resolved. The issue, which temporarily impacted system availability, has been addressed. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Thank you for your continued trust.

Updated
Apr 14, 2026 at 1:33pm UTC

We have found the root cause and have mitigated the incident. We are seeing our performance return to normal levels but are continuing to monitor the progress closely. We will update in the next 15 mins to ensure that performance has stayed consistent.

Created
Apr 14, 2026 at 12:12pm UTC

We are currently experiencing an issue affecting some users' ability to access our services. Our team is actively working to resolve the problem and restore normal functionality. We will provide updates as soon as more information becomes available.