Data Viewing Issue on Vista Board
Resolved
Apr 14, 2026 at 7:11pm UTC
We are pleased to inform you that the issue with viewing data on Vista Board has been successfully resolved. We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, the service is now stable and functioning as expected. If you experience any further issues or have questions, please don't hesitate to contact us. Thank you for being a valued customer. We will follow up here with a full RCA to share more details and how we will prevent this and future incidents recurring.
Affected services
Updated
Apr 14, 2026 at 6:38pm UTC
We are pleased to announce that we the applied fixes are working as intended. We will continue to monitor and update if there are any changes.
Affected services
Updated
Apr 14, 2026 at 5:45pm UTC
We are happy to confirm that all regions mitigations have completed successfully. We are seeing normal response rates, and Vistas operating as expected. We are continuing to monitor over the next hour to ensure there are no residual issues. If we don't see any further issues we will mark the issue resolved. \
\
We deeply apologize for this. This is not acceptable to us and will endeavor this doesn't happen again. We will report with a complete RCA here as soon as it is ready.
Affected services
Updated
Apr 14, 2026 at 4:54pm UTC
We have confirmed that all orgs in all regions except for AP South have been successfully resolved. We are continuing to monitor this progress. We will update here as the AP South progress continues.
Affected services
Updated
Apr 14, 2026 at 3:43pm UTC
The mitigation has completed in our EU and AP Northeast regions. We are seeing all customers in those regions return to normal operations, as expected. We are still processing in the US and AP South and AP Southeast regions. We anticipate this will take an hour to complete. Thank you for your continued patience as we continue to monitor.
Affected services
Updated
Apr 14, 2026 at 3:35pm UTC
The mitigation is still processing across all affected regions and we are seeing many Orgs return to normal operations, workflow lag has gone to zero, and Vistas are now displaying all items. We will continue to monitor to ensure all affected regions and customers are resolved.
Affected services
Updated
Apr 14, 2026 at 3:15pm UTC
We have applied a fix which will allow for the new tickets and updates to process normally. We are seeing the error rates reduce for these. We are still processing the mitigation for the Vista views issues and will update you momentarily when that mitigation is complete.
Affected services
Updated
Apr 14, 2026 at 2:45pm UTC
We have identified the root cause and are currently applying mitigation steps. We expect these steps to take approximately 30-45 mins to complete. We will continue to update you as this progresses.
Affected services
Created
Apr 14, 2026 at 1:01pm UTC
We are currently experiencing a temporary issue affecting data display on Vista Board. Our team is actively working to resolve the problem and restore full service. We appreciate your patience and will provide updates as soon as more information is available.
Affected services