Delayed notifications and workflow processing for comment based events
Resolved
May 14, 2026 at 2:04pm UTC
We are pleased to inform you that the issue with delays in SLA processing, notifications, and comment-based workflows has been resolved. Note that though there were delays, no events were lost. We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, the service is now stable and functioning as intended. If you experience any further issues or have questions, please don't hesitate to reach out to our support team.
Affected services
Created
May 14, 2026 at 5:50am UTC
We're currently experiencing a service issue affecting a subset of orgs in the US East region. This is causing delays in SLA processing, notifications, and comment-based workflows. Our team is actively investigating and working on a fix. We'll provide updates as we have more information.
Affected services