Back to overview
Degraded
Issue Accessing the DevRev App
Jun 25, 2026 at 1:56pm UTC
Affected services
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Created
Jun 25, 2026 at 1:56pm UTC
We are currently experiencing a temporary issue that may prevent some users from accessing the DevRev app. The issue is related to a third-party provider and is primarily affecting users accessing from the South India region. Our team is actively working with the provider to resolve the problem and restore normal service. We appreciate your patience and will provide updates as soon as possible.
Affected services