Intermittent application unresponsiveness in EU region
Resolved
Jul 10, 2026 at 10:55am UTC
We are pleased to inform you that the recent issue causing the app and computer to become unresponsive has been successfully resolved. Our team identified and addressed the underlying cause to restore normal operation. We apologize for any inconvenience this may have caused and appreciate your patience and understanding during the process. Rest assured, the service is now stable and functioning as expected. If you experience any further issues or have concerns, please do not hesitate to contact us.
Affected services
Created
Jul 10, 2026 at 10:04am UTC
Some users in the EU region may experience the application becoming unresponsive or slow to load. Our team has identified the cause and is actively working on a fix. We will provide updates as we make progress.
Affected services