Back to overview
Resolved
Degraded performance in Mumbai region due to maintenance
Aug 7, 2026 at 6:58pm UTC
Affected services
Application (app.devrev.ai)
API (api.devrev.ai)
Resolved
Aug 7, 2026 at 7:51pm UTC
The maintenance work has concluded and the performance issues experienced in the ap-south-1 (Mumbai region) have been fully resolved. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time.
Affected services
Created
Aug 7, 2026 at 6:58pm UTC
We are currently experiencing slower performance in the ap-south-1 region (Mumbai) following recent maintenance. Our team is actively working to resolve the issue and restore normal service. We will keep you updated as we make progress.
Affected services