Back to overview
Resolved

Async processes experiencing delays

Aug 19, 2026 at 4:42am UTC
Affected services
Application (app.devrev.ai)
Timeline
Workflows and Automations
Timeline
Workflows and Automations
Timeline
Workflows and Automations
Timeline
Workflows and Automations
Timeline
Workflows and Automations

Resolved
Aug 19, 2026 at 12:13pm UTC

We are pleased to inform you that the backlog has been drained and all async workloads are back to normal

Created
Aug 19, 2026 at 4:42am UTC

We are currently experiencing a temporary increase in latency in async processes like webhooks, notifications, etc.