Back to overview
Resolved

Application down — users unable to connect

Aug 27, 2026 at 10:35am UTC
Affected services
Application (app.devrev.ai)
Authentication (auth.devrev.ai)
Computer
Application (app.devrev.ai)
Authentication (auth.devrev.ai)
Computer
Application (app.devrev.ai)
Authentication (auth.devrev.ai)
Computer
Application (app.devrev.ai)
Authentication (auth.devrev.ai)
Computer
Application (app.devrev.ai)
Authentication (auth.devrev.ai)
Computer

Resolved
Aug 27, 2026 at 11:11am UTC

This incident is now resolved. After a period of monitoring, login and connectivity are fully stable and operating normally. The issue was caused by a problem with a third-party authentication provider, which has since been fully restored.

We apologize for the inconvenience this may have caused and thank you for your patience throughout.

Updated
Aug 27, 2026 at 11:04am UTC

The issue affecting login and connectivity has been resolved, and access is now operating normally. This was caused by an issue with a third-party authentication provider.

We are continuing to monitor closely to ensure full stability. We apologize for the inconvenience and thank you for your patience.

Created
Aug 27, 2026 at 10:35am UTC

We're aware some users are currently unable to connect to the application, and we're sorry for the disruption. Our team is actively investigating and working to restore full access as quickly as possible. We'll share updates as we learn more. Thank you for your patience.