Back to overview
Resolved

Degraded Performance in ap-south-1

Aug 31, 2026 at 8:35am UTC
Affected services
Application (app.devrev.ai)
API (api.devrev.ai)

Resolved
Aug 31, 2026 at 9:00am UTC

Performance in ap-south-1 has returned to normal, and the issue affecting some users has been fully resolved. We've confirmed services are operating as expected. Thank you for your patience, and we apologize for any inconvenience caused.

Created
Aug 31, 2026 at 8:35am UTC

We are currently investigating reports of degraded performance affecting some users in the ap-south-1 region. You may experience slower-than-usual response times or intermittent errors. Our team has identified the issue and is actively working on a resolution. We apologize for the inconvenience and will share updates as they become available.