Back to overview
Resolved
Degraded Performance in us-east-1
Aug 31, 2026 at 5:47pm UTC
Affected services
Application (app.devrev.ai)
Search
Workflows and Automations
Resolved
Aug 31, 2026 at 8:36pm UTC
Performance in us-east-1 has returned to normal. We've confirmed services are operating as expected. Thank you for your patience, and we apologize for any inconvenience caused.
Affected services
Created
Aug 31, 2026 at 5:47pm UTC
We are currently experiencing an issue where some workflows are not triggering in the us-east-1. Our team is actively working to resolve this and will provide updates as soon as possible. We appreciate your patience and understanding.
Affected services