Back to overview
Downtime

Loading issues with customer Support portal

Sep 13 at 05:30am UTC
Affected services
Support Portal (support.devrev.ai)

Resolved
Sep 13 at 06:00am UTC

We experienced loading issues with DevRev's customer Support portal (https://support.devrev.ai/devrev)
The Outage persisted from 11.00AM till 11.30AM IST.
The services are now restored and customer support portal is up and running again.
We apologize for any inconvenience caused during the above timeframe

Created
Sep 13 at 05:30am UTC

We’re experiencing loading issues with DevRev Customer Support portal. We apologize for any inconvenience and will post another update as soon as we learn more.