Back to overview
Degraded

Issue with Accessing Devrev App

Oct 22 at 07:35am UTC
Affected services
Application (app.devrev.ai)

Resolved
Oct 22 at 07:54am UTC

The underlying issue has been fixed and the service is now stable. We apologize for any inconvenience this may have caused and appreciate your patience. Rest assured, the service is now stable, but please don't hesitate to contact us if you encounter any further issues. Thank you for your understanding.

Created
Oct 22 at 07:35am UTC

We are currently experiencing difficulties with loading the Devrev App. Our team is actively working on resolving this issue. We apologize for any inconvenience caused and appreciate your patience. Updates will be provided as soon as possible.