Back to overview
Degraded

Slack Service Disruption Affecting Integrations

Feb 26 at 03:30pm UTC
Affected services
Conversation and Ticket Management
Issue Management
Conversation and Ticket Management
Issue Management
Conversation and Ticket Management
Issue Management

Resolved
Feb 27 at 02:36pm UTC

We are pleased to inform you that the issue with Slack being down and the Slack to Devrev integration not functioning has been resolved. We appreciate your patience and apologize for any disruption this may have caused.

Created
Feb 26 at 03:30pm UTC

We are currently facing a disruption with our Slack service that is affecting the Slack to DevRev integration. Our team is actively monitoring Slack's progress on the fix and will provide updates as soon as possible. Thank you for your patience during this time.