Back to overview
Degraded

Issue with Invitation Process

Apr 02 at 06:30pm UTC
Affected services
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)

Resolved
Apr 03 at 06:09am UTC

We are pleased to inform you that the issue with the broken invite flow has been successfully resolved. Our team identified the problem and implemented a hotfix to restore the functionality.

Created
Apr 02 at 06:30pm UTC

We are currently experiencing an issue with our invitation process, which may affect your ability to send or receive invites. Our team is actively working to resolve this matter and we will provide updates within the next few hours. Thank you for your patience as we work to restore full functionality.