Back to overview
Degraded

Issue with Email Integration Not Displaying Emails

May 21, 2026 at 7:30pm UTC
Affected services
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)
Application (app.devrev.ai)

Resolved
May 21, 2026 at 8:57pm UTC

The issue causing failures in creating discussions from emails has been resolved. We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. If you experience any further issues or have questions, please do not hesitate to contact our support team.

Created
May 21, 2026 at 7:30pm UTC

We are experiencing an issue that is preventing some emails from appearing in the discussions panel. Our team is actively working to resolve the problem and restore full service. We appreciate your patience and will provide updates as soon as possible.