Delays in record updates and notifications
Resolved
Jun 18, 2026 at 12:32pm UTC
We are pleased to inform you that notification and webhook delivery is fully restored. The event backlog has been completely processed and delivery times are back to normal. No data was lost. We apologize for the inconvenience and thank you for your patience.
Affected services
Created
Jun 18, 2026 at 7:56am UTC
Some users may experience delays in record updates (including ticket/work-item changes and assignments) and in notification and webhook delivery. Updates are queued and being processed — no data is lost. Our team is actively investigating and working to restore normal processing times. We will continue to provide updates as the situation progresses.
Affected services