Back to overview
Resolved

Delays in automated workflow execution

Jul 24, 2026 at 10:33am UTC
Affected services
API (api.devrev.ai)
Timeline
Workflows and Automations
API (api.devrev.ai)
Timeline
Workflows and Automations

Resolved
Jul 24, 2026 at 12:32pm UTC

This issue is now resolved. Workflows, event updates, SLAs, snap-ins, and webhook callbacks are processing normally, and the backlog has fully cleared. Thank you for your patience.

Updated
Jul 24, 2026 at 11:59am UTC

We've identified the cause of the delays affecting automated workflows, timeline events, SLAs/OLAs, snap-ins, and webhook callbacks. A fix is currently being rolled out across affected regions and we expect recovery to begin shortly as the fix takes effect. We'll post the next update once we confirm systems are catching up.

Created
Jul 24, 2026 at 10:33am UTC

We've identified that delays are being caused by processing lag in our event pipeline, which is impacting automated workflows, timeline events (updates on tickets/issues), SLAs, and snap-ins. Some webhook callbacks may also be delayed. Workflows and events are still processing, but you may continue to see delays until recovery completes. We'll post the next update shortly.