Elevated Latency in the ap-south-1 Region
Resolved
Aug 3, 2026 at 1:34pm UTC
We are pleased to inform you that the recent latency issues have been resolved. We sincerely apologise for any inconvenience this may have caused and appreciate your patience and understanding during this time. Rest assured, our services are now stable and functioning as intended. If you experience any further issues or have questions, please do not hesitate to contact our support team. Thank you for your continued trust.
Affected services
Created
Aug 3, 2026 at 7:50am UTC
We are currently observing elevated latency in the ap-south-1 region, which may result in slower response times or intermittent delays across some services and features. Our team is actively investigating the issue and working to mitigate the impact. We will provide updates as more information becomes available.
Affected services